Sahlad

Members
  • Content count

    18
  • Joined

  • Last visited


Sahlad's Activity

  1. Sahlad added a post in a topic Hur man lägger in en ny mjukvara i sin box   

    Ett försök att göra det lite mer detaljerat, efter att ha spenderat för mycket tid på det här genom trial error... Notera att nedan är endast testad på "Miraclebox Premium Twin+" och med Egami.
    1. FAT32-formatera ett USB minne. Om du kör Windows10 kan det vara lite struligt, men guider finns att hitta på nätet, exempelvis den här: https://www.partition-tool.com/resource/manage-partition/format-usb-flash-drive-in-windows-10.html
    2. Ladda ner senaste versionen av Egami. Det finns en länk som pekar dit ifrån det här forumet som ser ut så här: http://image.egami-image.com/index.php?open=mbtwinplus men när jag försökte så var listan tom av någon anledning och jag fick ta fram hela listan på historiska images: http://image.egami-image.com/image-archive/index.php?open=mbtwinplus. (På Egamis sida så avser "Miracle Twin" modellen "Miracle Premium Twin" och "Miracle Twin Plus+" avser "Miracle Premium Twin+"). Filen som ska laddas ner är en zip-fil och heter något i stil med "egami-8.0.6-mbtwinplus-20171024_usb.zip", men för din del antagligen med högre versionsnummer än 8.0.6 och senare datum än 20171024.
    3. Packa upp filen och lägg innehållet i roten på USB-minnet. Direkt på USB-minnet kommer det då ligga en mapp som heter "miraclebox". I den mappen ligger endast en mapp som heter "twinplus". I twinplus-mappen ligger själva installationsfilerna.
    4. Bland installationsfilerna så finns det en fil som heter "noforce". Byt namn på den filen så att den heter "force" (tack @engeln!).
    5. Se till att Miraclebox är avstängd med 1/0-knappen på baksidan.
    6. Öppna luckan för programkortet (i mitt fall comhem-kortet). Till vänster om kortet/n sätter du i USB-minnet USB-uttaget.
    7. Starta Miraclebox med 1/0-knappen på baksidan
    8. Om allt går som det ska så kommer det stå "Writing splash" följt av "Writing root" istället för "starting linuxTV" som i vanliga fall. Strax efter så kommer "starting linuxTV" ändå :).
    9. Följ anvisningarna för att konfigurera egami. För alla Stockholmsbor så kan jag även tipsa om att comhems nätverksID är 41001, så slipper du leta upp det med Bor du på andra ställen så kan du alltid hitta det på comhems sida: https://www.comhem.se/asset/2zxwgcm7u48q/grundinstallningar-for-digital-tv/32fce75ab3f4d0c49ff94486ce411861/grundinstallningar-for-digital-tv-data.pdf
    10. Ta ut USB-minnet från Miraclebox... Annars behöver du installera om allt från början vid nästa omstart.
    Och glöm inte att först köpa och sätta i CA-modulen för comhem, om det är comhem-kanaler som du har tänkt att titta på.
  2. Sahlad added a post in a topic MB Premium Software - Miraculous v1.3   

    Det visade sig att jag missat att jag behövde ringa comhem och be dem paira om. När jag gjort det så funkade det bra att se kodade kanaler. Men - Det kraschar fortfarande när jag försöker gå in i "Common Interface tilldelning", vilket verkar vara en ren bugg.
  3. Sahlad added a post in a topic Kan någon tyda dessa crashloggar?   

    Efter att ha läst lite fler loggar och kollat dina loggar igen så lyckas jag förhoppningsvis tolka dem lite bättre:
     
    Den sista loggen ser ut som när du har varit inne i "Common Interface tilldelning", eller "Common Interface Assignment" som det står på engelska. Efter att ha lämnat den delen i menyn så har du senare gått in där igen. Det är då den kraschar. Det spelar ingen roll om du gör något alls i den delen av menyn, så länge du har varit där. Å andra sidan, har du gjort korrekt inställningar första gången så behöver du inte gå in där igen och ändringarna som görs verkar slå igenom. Felet finns i defaultskin för både Miraculous och Egami, men jag tycker fortfarande att kraschen verkar bero på skinet. Jag har själv samma problem men har inte hittat nåt skin som funkar.
     
    I första och mittenloggen så verkar något försöka sparas, men den klagar på att filen som den försöker spara till inte finns. Min gissning här är att det snarare är mappen/enheten som filen ska sparas på som inte finns.
  4. Sahlad added a post in a topic Miraclebox Premium COMBO - Comhem   

    Svaret på min egen fråga är antagligen att ringa comhem och be dom göra om pairing, iom att jag flyttat kortet från en HD-box. Nu sitter kortet i en CI+ kompatibel CAM som är insatt i boxen, så nu är det där pairing är uppsatt, så jag kan inte verifiera om min teori stämmer för de inbyggda slottarna eller inte.
  5. Sahlad added a post in a topic Hur ser jag om slottarna hittas?   

    Och nu har jag konstaterat att det åtminstone inte är fel på CAM-slottarna. Efter att com hem "pairat om", eller vad det nu kallas för, så får jag åtminstone in kodade kanaler den vägen. De interna slottarna fungerar eventuellt ändå inte - men jag vet inte om comhem behöver ta bort pairing helt eller nåt för att de ska funka i så fall, eftersom att de inte stödjer CI+. Jag nöjer mig med att det fungerar som det är i alla fall.
     
    Felet som beskrivs ovan, som uppstår i "Common Interface tilldelning" kvarstår fortfarande, men så länge jag får in kanalerna känner jag inte att jag behöver in i den menyn mer. Jag får däremot anta att det är mjukvarufel det är frågan om och att det ligger i Enigma2, eftersom att det finns både i Miraculous och Egami.
  6. Sahlad added a post in a topic Hur ser jag om slottarna hittas?   

    Har förresten testat med Miraculous-imagen och det blir fortfarande samma fel där, med utdrag ur crash-loggen:
     
    [OpenWebif] page '/api/remotecontrol?command=352' ok (json)
    KEY: 352 OK
    action ->  SetupActions ok
    [CI_Wizzard] selected CI Slot : 0
    [CI_Wizzard_Config] Configuring CI Slots : 0
    [2816L, 2817L, 2818L, 2819L, 2820L, 2821L, 2822L, 2823L, 2824L, 2825L]
    [CI_Wizzard_Config_CI0] read following CAIds from CI: [('0xb00', '2816', 1), ('0xb01', '2817', 2), ('0xb02', '2818', 3), ('0xb03', '2819', 4), ('0xb04', '2820', 5), ('0xb05', '2821', 6), ('0xb06', '2822', 7), ('0xb07', '2823
    ', 8), ('0xb08', '2824', 9), ('0xb09', '2825', 10)]
    [CI_Config_CI0] error parsing xml...
    Screen <class 'Plugins.SystemPlugins.CommonInterfaceAssignment.plugin.CIconfigMenu'>((0,), {}): <type 'exceptions.AttributeError'>
    Traceback (most recent call last):
      File "/usr/lib/enigma2/python/mytest.py", line 260, in create
        return screen(self, *arguments, **kwargs)
      File "/usr/lib/enigma2/python/Plugins/SystemPlugins/CommonInterfaceAssignment/plugin.py", line 160, in __init__
      File "/usr/lib/enigma2/python/Plugins/SystemPlugins/CommonInterfaceAssignment/plugin.py", line 304, in loadXML
    AttributeError: 'CIconfigMenu' object has no attribute 'read_services'
    Traceback (most recent call last):
      File "/usr/lib/enigma2/python/Components/ActionMap.py", line 46, in action
      File "/usr/lib/enigma2/python/Plugins/SystemPlugins/CommonInterfaceAssignment/plugin.py", line 85, in greenPressed
      File "/usr/lib/enigma2/python/mytest.py", line 345, in open
        dlg.isTmp = True
    AttributeError: 'NoneType' object has no attribute 'isTmp'
    (PyObject_CallObject(<bound method ActionMap.action of <Components.ActionMap.ActionMap instance at 0x1d94120>>,('SetupActions', 'ok')) failed)
    ]]>
  7. Sahlad added a post in a topic MB Premium Software - Miraculous v1.3   

    @LowDead, nope
    Har satt i en CAM nu också, men det funkar inte heller. Konstanta krascher hela tiden, så fort jag försöker editera inställningarna för "Common Interface tilldelning" och jag kommer fortfarande inte åt några kodade kanaler.
     
    Jag misstänker starkt hårdvarufel på min box, så jag ska bara hitta lämpligt tillfälle att skicka tillbaks den för lagning/garantiärende.
     
    Barnen är i alla fall glada... Barnkanalen är ju okodad... :/
  8. Sahlad added a post in a topic Hur ser jag om slottarna hittas?   

    Hittade två rader som verkar vara återkommande i de olika felmeddelandena och kanske har något med allt att göra:
     
    File "/usr/lib/enigma2/python/Plugins/SystemPlugins/CommonInterfaceAssignment/plugin.py", line 304, in loadXML
    AttributeError: 'CIConfigMenu' object has no attribute 'read_services'
     
    Någon som vet om det går att editera filen manuellt med de värden som behövs?
  9. Sahlad added a post in a topic Hur ser jag om slottarna hittas?   

    Jag ser inte ens att accesslampan lyser.
    Nu har jag äntligen fått comhem-CAMen och efter lite konstaterande så kraschar fortfarande Egami när jag börjar ändra i "Common Interface tilldelning". Om jag endast tilldelar CAIds, men inga kanaler så kraschar den pga saknade uppgifter nästa gång jag går in i den menyn. Samma sak om jag tilldelar den kanaler men inte CAIds. Det blir även en krasch, men med annat fel, om jag försöker lägga till kanaler och väljer alternativet "alla". Och, såklart, krasch om jag tilldelar både CAIds och kanaler men då också annan typ av fel.
     
    När barnen tillåter att barnkanalen är avstängd en stund så blir det till att installera Miraculous igen och se om det gör någon skilnad när jag har en CAM. Men gissningsvis så får det bli ett garantiärende på den här boxen
  10. Sahlad added a topic in Allmänt om Hårdvara   

    Hur ser jag om slottarna hittas?
    Jag har i någon vecka nu kämpat med min MBP, men kan fortfarande inte titta på kodade kanaler - endast ettan, tvåan och fyran.
     
    Jag är en newbie när det gäller smartare dekodrar, varför jag har tagit för givet att jag bara inte hittat rätt inställningar eller plugins för att få det att fungera, men nu börjar jag tro att mina slottar i boxen överhuvudtaget inte hittas. Jag har först testat Miraculous utan att få det att fungera, inte ens efter att installerat cardreader-pluginet. När inget funkade så har jag nu gått över till Egami image 4.4.0. Med Egami kan jag inte hitta att jag ska behöva installera några plugins för att kort-slottarna ska hittas, men jag kan fortfarande inte se att de hittas och inga kodade kanaler avkodas. I någon tidigare tråd kunde jag hitta att det skulle stå vilken slot som användes när man klickade på OK-knappen. Själv kan jag se vilken tuner som används, men inte vilken slot. Egami visar lite mer info än Miraculous, men jag ser som sagt bara att kanalen är kodad, inte att något försök görs för att den ska avkodas:
     

     
    och signalen ser det inte ut att vara något fel på:
     

     
    Går jag in i menydelen för Common Interface så säger den att "ingen modul hittad". Men newbie som jag är så vet jag inte om det betyder att den inte hittar slottarna eller om det bara beror på att jag inte har satt i någon CAM med kort i ännu. Jag vet inte om det ska gå, men om jag i menyn försöker klicka för att "Initiera", för att se om någon modul hittas eller åtminstone försöker hittas, så händer ingenting:
     

     
    Även under tilldelning av Common Interface kan jag se att "ingen modul hittad". Om jag försöker "Ändra" så hårdkraschar boxen och jag måste starta om den med på/av-knappen på baksidan. Vid något tillfälle så illa att jag även var tvungen att ominstallera imagen från början.
     
    Är det någon som kan avgöra om det här är ett hårdvarufel - dvs att slottarna inte hittas - eller är det trots allt någon ytterligare plugin, drivrutin eller liknande som jag behöver installera för att de ska kunna hittas?

    • 5 replies
    • 1,117 views
  11. Sahlad added a post in a topic Kan någon tyda dessa crashloggar?   

    Jag har visserligen inte läst såna loggar tidigare eller utvecklat så mycket i Python, men... Loggarna klagar väldigt mycket på saknade och saknade element till det skin som jag gissar är inställt att användas. På sluttampen är det något som försöker sparas till en fil som inte hittas. Jag skulle nog börja med att byta skin i alla fall, för att se om det hjälpte.
  12. Sahlad added a post in a topic MB Premium Software - Miraculous v1.3   

    Upplever samma sak - SC1 och SC0 visas aldrig någonstans.
    Jag undrar även - är det här senaste versionen av Miraculous och enda stället att ladda ner det ifrån eller finns det senare uppdateringar någon annanstans? Eftersom att jag inte tydligt kan se vad som inte fungerar när kodade kanaler inte visas så har jag nu även testat Egami - som verkar vara bättre uppdaterat och lite tydligare, även om det inte är helt tydligt där heller,
  13. Sahlad added a post in a topic Miraclebox Premium COMBO - Comhem   

    Kan förresten konstatera att det inte verkar spela någon roll vad jag skriver som nätverks-id. Den hittar lika många kanaler oavsett. Däremot så lyckas den aldrig avkoda några kodade kanaler, typ TV3, Kanal5 osv. Sliter mitt hår med det där och undrar om C-tunerna i min box fungerar överhuvudtaget, eller om jag bara inte fattar vad jag ska göra för att de ska börja användas?
  14. Sahlad added a post in a topic SVT play   

    Skulle också vilja ha SVT-play i boxen... Inget vettigt svar på 6 månader... "Det finns inte, du får hacka ihop en egen plugin" hade varit ett bättre svar än inget, men det kanske inte är någon som kan svaret?
  15. Sahlad added a post in a topic ** Ge nya Tips på guider **   

    Och... Nu har jag ändå letat rätt mycket utan att komma någon vart... En grundlig steg för steg - guide för att komma igång och kolla på kodade kanaler överhuvudtaget hade ju inte varit helt fel. Ingenting fungerar ju out of the box så förslag till början:
     
    0. Koppla box till TV, dra TV-sladd till boxen och anslut boxen till ett eluttag.
    1. Innan du ens startar boxen första gången - förbered installera av en image, föreslagsvis Miracolous. Ladda ner filen "MB Premium Twin HD Vxxxx" för din premium-modell från http://www.miraclebox.se/downloads.html. Öppna zipfilen och kopiera hela "miraclebox"-mappen till ett FAT32-formaterat USB-minne.
    2. Första gången du startar boxen - installera en image ifrån USB-minne. Sätt in minnet i USB-ingången på fronten, bakom luckan till kortplatserna. När boxen startas så välj att genomföra installationen när frågan kommer upp.
    3. ...
     
    Jag vet inte om jag har gjort allt i optimal ordning och / eller helt rätt. Men i dagsläget så får jag upp en lista på 188 kanaler, men jag kan bara se de som är helt okrypterade och okodade. Det senaste som jag har gjort är att installera "Cardreader Plugin for MB Premium" från http://miraclefiles.net/index.php?download=136. Inte heller där var det ju uppenbart hur det skulle gå till - tex att det var valet "Installation > Mjukvaruhantering > Install local addons" som jag skulle in i (och inte direkt i Plugin tex). Sen var det ju inte uppenbart att filerna på USBn ligger på "media/hdd" när de ligger i roten på minnet... (jag fick telnetta till burken och leta upp var filerna fanns för att fatta det).
     
    Och uppenbarligen så räcker det inte där, för jag kan fortfarande bara se okodade och okrypterade kanaler... Resten är utan bild och utan ljud.