M9 - V2.11.34 / V2.11.34 CI+

89 posts in this topic

Posted · Report post

I ett sista desperat försök att få till EPG, så körde jag EPG-cleaner, vilket resulterade i ett annat fenomen.

Nu står MB9:an och bootar om...i all oändlighet.

Snart blir det bojsänke av eländet... :evil:

Om xxx är yyy får boxen lida... :mrgreen:

Du har satt Plugin : epg-cleanup i Autostart , det skulle du EJ gjort.

Skrev ihop ett enkelt plugin som kan hjälpa dig och boxen till att vara i mer harmoni.

Den skriver över filen /var/bin/autorun.sh som innehåller alla autostarter av Plugin.

tom_autorun.zip

Sedan får du aktivera Autostart för ex softcam ( Mcas) eller igen.

/Mvh Ants war :D

Share this post


Link to post
Share on other sites

Posted · Report post

Om xxx är yyy får boxen lida... :mrgreen:

Du har satt Plugin : epg-cleanup i Autostart , det skulle du EJ gjort.

Skrev ihop ett enkelt plugin som kan hjälpa dig och boxen till att vara i mer harmoni.

Den skriver över filen /var/bin/autorun.sh som innehåller alla autostarter av Plugin.

[attachment=0]tom_autorun.zip[/attachment]

Sedan får du aktivera Autostart för ex softcam ( Mcas) eller igen.

/Mvh Ants war :D

Vad skulle våra boxar vara utan dig Ants War? :thumbup: :thumbup: :thumbup:

Angående mitt problem med förlorade timerinställningar så hittade jag en ny lösning på problemet. Det finns ju i menyerna under Tidsinställningar en funktion för automatisk nedstängning och väckning av boxen.

Nu har jag kombinerat detta med scriptet som raderar EPG.txt och gör reboot. Verkar funka faktiskt...

Från menyn, inställt för daglig avstängning tex kl 03.45

EPGCleanup startat av cron:

55 3 * * * rm /STORAGE/HDD/epg.txt

55 3 * * * standby

57 3 * * * wake up

0 4 * * * sync;sync;sync;/sbin/reboot -f

Från menyn, inställt för daglig uppstart tex kl 18.00 vilket blir tiden då ny EPG börjar läsas in.

Dock verkar funktionen för att ställa in uppstart och avstängning via menyn inte vara helt stabil eller i alla fall inte bete sig som väntat. Tex så tog den inga inställningar av uppstart om jag först valt en nedstängningstid.

Nedstängning innebar vid första testen Standby, men senare har den gått ned i Djup Standby. Cron tickar och går dock så den bootar ju om ändå och läser in ny EPG. Vi får väl se hur den bestämmer sig för att fungera framgent...

Problemet verkar i alla fall löst! :)

Share this post


Link to post
Share on other sites

Posted · Report post

Vad skulle våra boxar vara utan dig Ants War? :thumbup: :thumbup: :thumbup:

Angående mitt problem med förlorade timerinställningar så hittade jag en ny lösning på problemet. Det finns ju i menyerna under Tidsinställningar en funktion för automatisk nedstängning och väckning av boxen.

Nu har jag kombinerat detta med scriptet som raderar EPG.txt och gör reboot. Verkar funka faktiskt...

Från menyn, inställt för daglig avstängning tex kl 03.45

EPGCleanup startat av cron:

55 3 * * * rm /STORAGE/HDD/epg.txt

55 3 * * * standby

57 3 * * * wake up

0 4 * * * sync;sync;sync;/sbin/reboot -f

Från menyn, inställt för daglig uppstart tex kl 18.00 vilket blir tiden då ny EPG börjar läsas in.

Dock verkar funktionen för att ställa in uppstart och avstängning via menyn inte vara helt stabil eller i alla fall inte bete sig som väntat. Tex så tog den inga inställningar av uppstart om jag först valt en nedstängningstid.

Nedstängning innebar vid första testen Standby, men senare har den gått ned i Djup Standby. Cron tickar och går dock så den bootar ju om ändå och läser in ny EPG. Vi får väl se hur den bestämmer sig för att fungera framgent...

Problemet verkar i alla fall löst! :)

EDIT: så här ser det ut...

Från menyn, inställt för daglig avstängning tex kl 03.45

EPGCleanup startat av cron:

55 3 * * * rm /STORAGE/HDD/epg.txt

0 4 * * * sync;sync;sync;/sbin/reboot -f

Från menyn, inställt för daglig uppstart tex kl 18.00 vilket blir tiden då ny EPG börjar läsas in.

Share this post


Link to post
Share on other sites

Posted · Report post

Om xxx är yyy får boxen lida... :mrgreen:

Du har satt Plugin : epg-cleanup i Autostart , det skulle du EJ gjort.

Skrev ihop ett enkelt plugin som kan hjälpa dig och boxen till att vara i mer harmoni.

Den skriver över filen /var/bin/autorun.sh som innehåller alla autostarter av Plugin.

[attachment=0]tom_autorun.zip[/attachment]

Sedan får du aktivera Autostart för ex softcam ( Mcas) eller igen.

/Mvh Ants war :D

Ja djävlar, fan man ska torsk på dom mest enkla grejorna :roll: , blev rätt så kokt burken i går kväll.

Nu blir det inget miracleboxande förrän i morgonkväll, tackar för tipset!

Share this post


Link to post
Share on other sites

Posted · Report post

Ja djävlar, fan man ska torsk på dom mest enkla grejorna :roll: , blev rätt så kokt burken i går kväll.

Nu blir det inget miracleboxande förrän i morgonkväll, tackar för tipset!

Det blev manuellt hackande i kombination med "VI" och en #, så var problemet urvärlden..men något störande :D

Share this post


Link to post
Share on other sites

Posted · Report post

Någon som vet skillnaden mellan FDU 1.3 och FDU 1.4?

Tömmer jag kanalinställningarna, och kör en kanalsökning från scratch så får jag EPG att fungera, fullt ut.

Men så fort jag editerar kanallistan ,med polaredit eller Dr.EditHD, så skiter det sig, jag får då EPG på vissa kanaler.

Share this post


Link to post
Share on other sites

Posted · Report post

Någon som vet skillnaden mellan FDU 1.3 och FDU 1.4?

Tömmer jag kanalinställningarna, och kör en kanalsökning från scratch så får jag EPG att fungera, fullt ut.

Men så fort jag editerar kanallistan ,med polaredit eller Dr.EditHD, så skiter det sig, jag får då EPG på vissa kanaler.

Sparas filen om som FDU 1.3 av polaredit och Dr.Edit?

Share this post


Link to post
Share on other sites

Posted · Report post

Jag vet inte skillnaden, men jag har kommit runt det med att ladda ner en av kanallistorna som ligger på miraclefiles, de har v1.3.

Öppna den i Polaredit. Sen öppnar man (eller hämtar via ftp) den som ligger i boxen. då har man två flikar med sina listor. Sen kan man kopiera från den som ligger i boxen till den som har v1.3 och sedan lägga på usb eller ftp:a in den i boxen.

Polaredit är väldigt smidigt för att ladda listor via ftp, men det är en bugg när man väljer tuner som jag inte kommit runt. Jag har en c-line på viaxxx som jag använder på en av mina tuners, och hur jag än väljer i polaredit så läggs viaxxx på bägge tuners. Så nu redigerar jag listan i Polaredit, sen får jag köra dr:edit för att välja tuners. ganska omständligt men det funkar.

Share this post


Link to post
Share on other sites

Posted · Report post

Så nu har jag ha en fungerande EPG igen. :)

Men det var en något knepig resa innan det fungerade igen, fick rensa kanalinställningar. Backa till en kanallista med FDU 1.3 (tog den på miraclefiles för visat och cd). Fick göra om SAT inställningar för T1 och T2, lägga om mina NAS inställningar. Sen hoppade det igång igen.

Alltihop började när jag fick tag i en kanallista med FDU 1.4....från en polare med samma box och programvara.

Känns som ett programvarufel kopplat till 2.11.34..

Share this post


Link to post
Share on other sites

Posted · Report post

Jag vet inte skillnaden, men jag har kommit runt det med att ladda ner en av kanallistorna som ligger på miraclefiles, de har v1.3.

Öppna den i Polaredit. Sen öppnar man (eller hämtar via ftp) den som ligger i boxen. då har man två flikar med sina listor. Sen kan man kopiera från den som ligger i boxen till den som har v1.3 och sedan lägga på usb eller ftp:a in den i boxen.

Polaredit är väldigt smidigt för att ladda listor via ftp, men det är en bugg när man väljer tuner som jag inte kommit runt. Jag har en c-line på viaxxx som jag använder på en av mina tuners, och hur jag än väljer i polaredit så läggs viaxxx på bägge tuners. Så nu redigerar jag listan i Polaredit, sen får jag köra dr:edit för att välja tuners. ganska omständligt men det funkar.

Har sedan uppdatering haft problem med krypterad kanal. Gjorde enligt ovan igår och sedan dess har jag inte haft någon krypterad kanal, så verkar tydligen vara någon bugg på något vis.

Share this post


Link to post
Share on other sites

Posted · Report post

Har sedan uppdatering haft problem med krypterad kanal. Gjorde enligt ovan igår och sedan dess har jag inte haft någon krypterad kanal, så verkar tydligen vara någon bugg på något vis.

Efter min uppgradering så hade jag samma problem, dock var det satellit inställningarna som blivit växlade. Shiftade tillbaka därefter ok. övriga plugin etc fungerade oförändrat.

Kan vara värt och kolla om du inte redan har gjort det.

Share this post


Link to post
Share on other sites

Posted · Report post

Hej !

Det enda nuvarande sätt som jag känner till får att kunna boxen i standby ifrån ett script är att använda FortisWebIo som ingår i följande plugin:

http://www.miracleforum.net/viewtopic.php?f=19&t=1839

Med ditt tidigare exempel som underlag:

55 3 * * * rm /STORAGE/HDD/epg.txt

55 3 * * * /var/www/cgi-bin/FortisWebIo mcmd=standby 2>/dev/null

57 3 * * * /var/www/cgi-bin/FortisWebIo mcmd=standby 2>/dev/null

0 4 * * * sync;sync;sync;/sbin/reboot -f

--

sync är er ett UNIX/Linux program som syncroniserar att filer är ordentligt lagrade på disk.

Att man gör det 3gånger är en gammal "yrkesskada" att se till att det blir ordentligt gjort, inför ex omstart eller

stopp av maskin.

PS ! Jag har Ej testat detta att det fungerar i sin helhet. Det får du gärna testa och återkomma om.

/Mvh Ants war :)

Hej igen,

Har nu testat alternativet med den inbyggda avstängningsfunktionen som kan aktiveras via menyn, under Tidsinställningar, vilket visade sig INTE funkar. Det såg ut att gå bra när jag först testade. Boxen verkade boota om som planerat men nu kan jag konstatera att så inte var fallet.

Har sedan testat ditt förslag Ants War, och nu fungerar det med några smärre justeringar.

FortisWebIo går utmärkt att använda men kommandot som jag fick att funka ser ut så här:

0 3 * * * /var/www/cgi-bin/FortisWebIo timerlist mcmd=standby

Så en Crontab som ser till att sätta boxen i Standby när den inte används, och samtidigt på ett korrekt sätt sparar alla timerinställningar, plus att varje natt rensa EPG vid vald tidpunkt sedan sparka igång den för att läsa in ny EPG kan tex se ut så här.

#sätt boxen i standby kl 3 varje natt

0 3 * * * /var/www/cgi-bin/FortisWebIo timerlist mcmd=standby

#radera EPG och boota om

0 4 * * * rm /STORAGE/HDD/epg.txt

0 4 * * * sync;sync;sync; /sbin/reboot -f

# starta upp boxen sent för att läsa in EPG och ha maximalt med info till kvällen...

0 18 * * * /var/www/cgi-bin/FortisWebIo timerlist mcmd=standby

Observera då att nyckeln här är FortisWebIo som behöver vara installerat enligt Ants War´s tips tidigare.

Share this post


Link to post
Share on other sites

Posted · Report post

well done, blir till att prova detta återkommer med rapport

Share this post


Link to post
Share on other sites

Posted · Report post

Brukar föra över inspelade TV-program från M9 till PC. Resultatet blir dock olika beroende på om TV-programmen förs över via nätverket eller via extern USB hdd, se nedan.

Vid överförning av inspelade TV-program från M9 via nätverk till PC erhålls felaktiga (konstiga) tecken för bokstäverna "å, ä, ö" i filnamnen. Ursprunglig datum och tid för inspelade TV-program bibehålls vilket är bra.

Vid överföring av inspelade TV-program från M9 till extern USB hdd erhålls rätt tecken för bokstäverna "å, ä, ö" i filnamnen. Ursprunglig datum och tid för inspelade TV-program försvinner och ersätts med tiden för filöverföringen vilket är dåligt.

Hur ska man göra för att få rätt tecken i filnamen samtidigt som ursprunglig datum och tid för inspelade TV-program bibehålls?

Som det är nu känns det som man får välja mellan pest eller kolera då inspelade TV-program ska överföras till PC.

Share this post


Link to post
Share on other sites

Posted · Report post

Brukar föra över inspelade TV-program från M9 till PC. Resultatet blir dock olika beroende på om TV-programmen förs över via nätverket eller via extern USB hdd, se nedan.

Vid överförning av inspelade TV-program från M9 via nätverk till PC erhålls felaktiga (konstiga) tecken för bokstäverna "å, ä, ö" i filnamnen. Ursprunglig datum och tid för inspelade TV-program bibehålls vilket är bra.

Vid överföring av inspelade TV-program från M9 till extern USB hdd erhålls rätt tecken för bokstäverna "å, ä, ö" i filnamnen. Ursprunglig datum och tid för inspelade TV-program försvinner och ersätts med tiden för filöverföringen vilket är dåligt.

Hur ska man göra för att få rätt tecken i filnamen samtidigt som ursprunglig datum och tid för inspelade TV-program bibehålls?

Som det är nu känns det som man får välja mellan pest eller kolera då inspelade TV-program ska överföras till PC.

Jag använder WinSCP för att föra över mina filer (Jag för bara över TS filen och redigerar i Project x): Har aldrig sett de problem du beskriver. Konstigt. Jag kör trådat mellan MB9 och Router och wiFi vidare till PC:n

//Spirou

Share this post


Link to post
Share on other sites

Posted · Report post

Felet med åäö brukar uppstå när man har fel codepage i samba... Har inte testat självpå mb:n men ska försöka ta en titt om ingen hinner före. Kör du samba pluginet? Version?

Share this post


Link to post
Share on other sites

Posted · Report post

Felet med åäö brukar uppstå när man har fel codepage i samba... Har inte testat självpå mb:n men ska försöka ta en titt om ingen hinner före. Kör du samba pluginet? Version?

Nej kör inte samba. När jag hämtar filer från M9 via nätverket till PC väljer jag "Kör" och \\192.xxx.x.xxx\ (nätverks adressen till M9) varefter jag får upp allt som ligger i M9 via utforskaren i windows 7, kopierar TV-programsfilerna i M9 och lägger dem på hdd i PC, funkar bra förutom att "å, ä, ö" i filnamen blir felaktiga (konstiga tecken).

Share this post


Link to post
Share on other sites

Posted · Report post

Kollade lite snabbt och default smb.conf har iso8859-9 och inte utf-8 som det borde vara då systemet har den codepage men /etc är read only. Hinner tyvärr inte kolla mer idag. Sjuka barn...

Någon kanske har koll på var man kan ändra smb konfigen? Verkar som / mountas som read-only? Kommer /etc från flash? Måste man köra samba pluginet för att kunna konfiga smbd?

Share this post


Link to post
Share on other sites

Posted · Report post

Tja, jag kör samba plugin men har nog samma problem egentligen.

\\Miraclebox\root\etc\samba\smb.conf

konfig ser ut så här i min

code page directory = /etc/samba/codepages

character set = iso8859-1

coding system = utf-8

case sensitive = yes

preserve case = yes

har även testat med iso8859-2 med ung. samma resultat.

bifogar hela filen ifall någon har intresse.

Testade att koperia en fil med åäö till NAS. I windows får åäö konstiga tecken, även på NASen samt även om de accessas från MB9. En annan sak som jag inte noterat tidigare. Om jag accessar från MB9 filen via nätverksdisk så funkar det normalt. Om jag accessar samma fil via från MB9 med DNLA så blir filen utan ljud? samt får inspelningsdatum = kopieringsdatum, så blir det inte via nätverksdisk. Ytterligare om jag kopierar samma fil istället från MB9 blå knapp till samma disk så verkar allt hänga med åäö datum och ljud. Några iakttagelser.

Share this post


Link to post
Share on other sites

Posted · Report post

Filtypen conf är inte tillåten, klipper in det istället

[global]

workgroup = WORKGROUP

server string = Miraclebox HD

netbios name = Miraclebox

security = share

socket options = SO_RCVBUF=65536 SO_SNDBUF=65536

# socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=65536 SO_SNDBUF=65536

# socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192

# socket options = TCP_NODELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192

large readwrite = yes

# max connections = 10

# max smbd processes = 10

# max stat cache size = 1024

read raw = yes

write raw = yes

wide links = no

# oplocks = no

# level2oplocks = no

log file = /tmp/log.%m

lock directory = /tmp

pid directory = /tmp

max log size = 50

smb passwd file = /tmp/smbpasswd

dns proxy = no

encrypt passwords = no

guest ok = yes

guest account = root

load printers = no

code page directory = /etc/samba/codepages

character set = iso8859-2

coding system = utf-8

case sensitive = yes

preserve case = yes

short preserve case = yes

[homes]

comment = Home Directories

browseable = no

writeable = yes

[sTORAGE]

; comment = STORAGE

path=/STORAGE

; only guest = yes

force user = root

writeable = yes

create mask = 0765

browseable = yes

guest ok = yes

[ROOT]

; comment = STORAGE

path=/

; only guest = yes

force user = root

writeable = yes

create mask = 0765

browseable = yes

[HDD]

; comment = HDD

path=/STORAGE/HDD

; only guest = yes

force user = root

writeable = yes

create mask = 0765

browseable = yes

guest ok = yes

[uSB1]

; comment = USB1

path=/STORAGE/USB1

; only guest = yes

force user = root

writeable = yes

create mask = 0765

browseable = yes

guest ok = yes

[uSB2]

; comment = USB2

path=/STORAGE/USB2

; only guest = yes

force user = root

writeable = yes

create mask = 0765

browseable = yes

guest ok = yes

[NET]

; comment = NET

path=/STORAGE/NET

; only guest = yes

force user = root

writeable = yes

create mask = 0765

browseable = yes

guest ok = yes

Share this post


Link to post
Share on other sites

Posted · Report post

edit: den kopierade filen från MB9 till NAS visserligen hängde åäö med men filen var korrupt och kunde inte spelas upp, reparation misslyckades...

Share this post


Link to post
Share on other sites

Posted · Report post

Tja, jag kör samba plugin men har nog samma problem egentligen.

\\Miraclebox\root\etc\samba\smb.conf

konfig ser ut så här i min

code page directory = /etc/samba/codepages

character set = iso8859-1

coding system = utf-8

case sensitive = yes

preserve case = yes

har även testat med iso8859-2 med ung. samma resultat.

bifogar hela filen ifall någon har intresse.

Testade att koperia en fil med åäö till NAS. I windows får åäö konstiga tecken, även på NASen samt även om de accessas från MB9. En annan sak som jag inte noterat tidigare. Om jag accessar från MB9 filen via nätverksdisk så funkar det normalt. Om jag accessar samma fil via från MB9 med DNLA så blir filen utan ljud? samt får inspelningsdatum = kopieringsdatum, så blir det inte via nätverksdisk. Ytterligare om jag kopierar samma fil istället från MB9 blå knapp till samma disk så verkar allt hänga med åäö datum och ljud. Några iakttagelser.

Kan du testa att sätta character set = iso8859-1 ?

Share this post


Link to post
Share on other sites

Posted · Report post

Försökte uppgradera min MB9 (direkt från fabrik - Firmware 2.11.07 bootloader 6.00)

till V2.11.34. Gick ej, fick "Error 1"

Provade att uppgradera till V2.11.30 Fungerade.

Provade återigen att uppgradera till V2.11.34 - "Error 8"

Tips/Förslag?

Share this post


Link to post
Share on other sites

Posted · Report post

Försökte uppgradera min MB9 (direkt från fabrik - Firmware 2.11.07 bootloader 6.00)

till V2.11.34. Gick ej, fick "Error 1"

Provade att uppgradera till V2.11.30 Fungerade.

Provade återigen att uppgradera till V2.11.34 - "Error 8"

Tips/Förslag?

Du beskriver Ej hur du försöker installera ny Firmware.

Det finns flera metoder.

Innan uppgradering:

Normalt skall rekommenderas att du har anslutit någon form av lagring: USB sticka, USB hårddisk eller

Intern hårddisk först . Givetvis skall de vara formaterade.

Om du installerar via en USB sticka:

från PC/Mac ; Ladda FW här ifrån: http://www.miraclebox.se/downloads.html

eller http://miraclefiles.net/index.php?category=1

Packa upp filen och lägg *.ird filen på den fat-32 formaterade USB stickan.

Anslut stickan till boxen.

Temporärt under installationen lagras en kopia av nuvarande FW på USB stickan , som när allt är klart tas bort.

Så om det krånglar formatera om USB sticka i din Miraclebox med vfat filsystem ( == fat32) och prova igen.

På senare FW går det installera ny FW via internet direkt ifrån boxen. Tror att även där behövs någon fungerande lagring på boxen.

/Mvh Ants war :)

Share this post


Link to post
Share on other sites

Posted · Report post

Du beskriver Ej hur du försöker installera ny Firmware.

Det finns flera metoder.

Innan uppgradering:

Normalt skall rekommenderas att du har anslutit någon form av lagring: USB sticka, USB hårddisk eller

Intern hårddisk först . Givetvis skall de vara formaterade.

Om du installerar via en USB sticka:

från PC/Mac ; Ladda FW här ifrån: http://www.miraclebox.se/downloads.html

eller http://miraclefiles.net/index.php?category=1

Packa upp filen och lägg *.ird filen på den fat-32 formaterade USB stickan.

Anslut stickan till boxen.

Temporärt under installationen lagras en kopia av nuvarande FW på USB stickan , som när allt är klart tas bort.

Så om det krånglar formatera om USB sticka i din Miraclebox med vfat filsystem ( == fat32) och prova igen.

På senare FW går det installera ny FW via internet direkt ifrån boxen. Tror att även där behövs någon fungerande lagring på boxen.

/Mvh Ants war :)

Ursäkta om jag var otydlig... :)

Jag har:

    Laddat ner filen precis från den plats du rekommenderar.
    Kört med en USB-sticka som varit formaterad.
    Packat upp *ird-filen till rooten på stickan.
    Satt in stickan i fronten på boxen.
    Tryckt röd knapp installera
    Väntat på att det blivit klart.

Till synes får jag några olika error-meddelanden. Har lagt upp en annan tråd där errorlista efterfrågas så att listan är lätt att hitta.

Det kan så klart ha blivit något fel vid överföringen/uppackningen av firmwaren till USBn. Ska prova att formatera om stickan och göra om, göra rätt.

Jag har haft en MB8 i några år och har framgångsrikt (utläses med lätt överklassaccent) genomfört flertalet uppdateringar både på min och andras boxar genom åren. Därför väntade jag mig inte alltför stora problem... Fast ofta kommer dessvärre den här krypande känslan av att nått alltid kan gå fel...

:D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now