Sign in to follow this  
Followers 0

Error when building Openmb image


1 post in this topic

Posted · Report post

I followed the simple five steps instruction to build my own Openmb image but unfortunately it stopped due to following:
 
ERROR: The recipe oe-alliance-branding is trying to install files into a shared area when those files already exist. Those files and their manifest location are:
   /home/nabotnik/openmb/open-pli-core/build/tmp/sysroots/mbmini/usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/public/static/remotes
 Matched in manifest-mbmini-enigma2-plugin-extensions-openwebif.populate_sysroot
Please verify which recipe should provide the above files.
The build has stopped as continuing in this scenario WILL break things, if not now, possibly in the future (we've seen builds fail several months later). If the system knew how to recover from this automatically it would however there are several different scenarios which can result in this and we don't know which one this is. It may be you have switched providers of something like virtual/kernel (e.g. from linux-yocto to linux-yocto-dev), in that case you need to execute the clean task for both recipes and it will resolve this error. It may be you changed DISTRO_FEATURES from systemd to udev or vice versa. Cleaning those recipes should again resolve this error however switching DISTRO_FEATURES on an existing build directory is not supported, you should really clean out tmp and rebuild (reusing sstate should be safe). It could be the overlapping files detected are harmless in which case adding them to SSTATE_DUPWHITELIST may be the correct solution. It could also be your build is including two different conflicting versions of things (e.g. bluez 4 and bluez 5 and the correct solution for that would be to resolve the conflict. If in doubt, please ask on the mailing list, sharing the error and filelist above.
ERROR: If the above message is too much, the simpler version is you're advised to wipe out tmp and rebuild (reusing sstate is fine). That will likely fix things in most (but not all) cases.
ERROR: Function failed: sstate_task_postfunc
ERROR: Logfile of failure stored in: /home/nabotnik/openmb/open-pli-core/build/tmp/work/mbmini-oe-linux/oe-alliance-branding/2.2+gitAUTOINC+5d5c043008-r1/temp/log.do_populate_sysroot.19763
ERROR: Task 553 (/home/nabotnik/openmb/open-pli-core/meta-openpli/recipes-openpli/enigma2-plugins/oe-alliance-branding.bb, do_populate_sysroot) failed with exit code '1'
NOTE: Tasks Summary: Attempted 3648 tasks of which 3031 didn't need to be rerun and 1 failed.
Waiting for 0 running tasks to finish:

Summary: 1 task failed:
  /home/nabotnik/openmb/open-pli-core/meta-openpli/recipes-openpli/enigma2-plugins/oe-alliance-branding.bb, do_populate_sysroot
Summary: There were 3 WARNING messages shown.
Summary: There were 3 ERROR messages shown, returning a non-zero exit code.
make: *** [image] Fel 1

 
I have tried to solve the matter by removing all files in .../build/tmp/ and then execute the

 > MACHINE=mbmini make image

command once again, but of course with same bad result.

 

How to solve this matter?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0